読者です 読者をやめる 読者になる 読者になる

vaguely

和歌山に戻りました。ふらふらと色々なものに手を出す毎日。

MacでRailsを使う時のメモ その2

Mac Ruby on Rails

今日もなぜかエラーが発生したのでメモ。

Railsチュートリアル第3章ほぼ静的なページの作成をやろうとして、GemfileにRubyのバージョンを2.1.5で設定したところ、以下のエラーが表示されました。

Your Ruby version is 2.0.0, but your Gemfile specified 2.1.5

調べてみたところ以下とほぼ同じ現象であったため、[gem install bundler] -> [rbenv rehash]を実行してみたところ問題が解決しました。

rbenv環境下でbundle installしたときにRubyのバージョンがおかしい場合の対処例 - ztbuz@dev

で、[bundle update]してみたところ、以下のインストール中にエラーが発生しました。 * nokogiri 1.6.4.1 * xpath 2.0.0 * sass 3.2.19

ただ、個別にインストールしたり(例: gem install nokogiri)もう一度[bundle update]を繰り返すと解消されたため、ネットワーク等の問題があったのかもしれません。

気になるところですが。